MCP Unavailable for some users
Started Jul 21, 2026, 1:48 AM UTC · Resolved Jul 21, 2026, 2:16 AM UTC
Investigating: We’ve seen elevated error rates when attempting to connect the MCP client to Flusterduck, and are actively working on a fix.
Jul 21, 2026, 1:48 AM UTC
Resolved: This issue is now resolved. Existing and new users will be able to connect the MCP from any MCP client.
Jul 21, 2026, 2:16 AM UTC
Postmortem
For 27 minutes on July 30, 2026, the MCP connection was unavailable for all users. This issue was due to a misconfigured variable that had become enforced in recent updates. The variable was added, and we redeployed the platform. We have now fully recovered and do not anticipate any further issues of this nature. We deeply apologize to any and all affected users and are taking steps to ensure issues such as this one are pre checked before deployment. Thank you.